MIKROTIK : Limit Download File Ekstensi Tertentu Menggunakan Layer7 Protocol

Pengguna/User Koneksi internet sering sekali melakukan download File/Film/Lagu dll untuk dirinya tanpa disadari Bandwidth yang dia gunakan akan mengganggu koneksi dari user lain. Untuk para administrator jaringan yang menggunakan Router mikrotik dapat menggunkan cara dengan cara membatasi kecepatan download berdasarkan ekstensi file yang di download oleh user menggunakan fitur Layer 7 Protocol pada Mikrotik RouterOs.

Cara nya akan saya tulis dibawah ini :

  1. Masuk ke terminal mikrotik (Bisa lewat Winbox/Telnet/Putty).
  2. Menambahkan regexp Script Layer 7 Protocol
    /ip firewall layer7-protocol
    add comment="File Besar" name=filebesar regexp="^.*get.+\\.(exe|rar|iso|zip|7zip|0[0-9][1-9]|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov).*\$"
    add comment="Dokumen" name=dokumen regexp="^.*get.+\\.(pdf|doc|docx|xlsx|xls|rtf|ppt|ppt).*\$"
    add comment="YOUTUBE" name=youtube regexp="http/(0\\.9|1\\.0|1\\.1)[\\x09-\\x0d ][1-5][0-9][0-9][\\x09-\\x0d -~]*(content-type: video)"

     

  3. Menambahkan Script Mangle
    /ip firewall mangle 
    add comment="File Besar" chain=prerouting layer7-protocol=filebesar action=mark-packet new-packet-mark=filebesar passthrough=yes
    add comment="DOKUMEN" chain=prerouting layer7-protocol=dokumen action=mark-packet new-packet-mark=dokumen passthrough=yes
    add comment="YOUTUBE" chain=prerouting layer7-protocol=youtube action=mark-packet new-packet-mark=youtube passthrough=yes

     

  4. Membuat Queue Tree
    /queue tree
    add name=GLOBAL parent=global-out
    add name=FILEBESAR parent=GLOBAL packet-mark=filebesar max-limit=1M
    add name=DOKUMEN parent=GLOBAL packet-mark=dokumen max-limit=2M
    add name=YOUTUBE parent=GLOBAL packet-mark=youtube max-limit=2M

    Limit ketika mendownload File yang masuk kategori filebesar adalah 1Mbps, untuk File dokumen adalah 2Mbps sedangkan koneksi untuk youtube adalah 2Mbps.

 

Selamat Mencoba & Semoga Bermanfaat
#Catatan Lama

 

Tinggalkan Balasan

This site uses Akismet to reduce spam. Learn how your comment data is processed.